googleAdsense_widever


update Flash Builder 4.5 to 4.6 Computer & Tools

FB(Flash Builder)버전별 차이

4.5(구버전) : 안드로이드만 빌드가능
4.5(신버전)~4.5.1 : iOS 빌드가능.

4.5.1 기준으로 AIR 2.6 버전 위에서 구동.

4.6 업데이트시
1) 컴포넌트 추가
2) 월등하게 빠르게 구동되는 릴리즈파일 (Adobe 공지 기준 4배)
3) AIR 3.1 위에서 구동함.


** Creative Suite 5.5에 포함된 FB 4.5.0을 4.6 버전으로 업데이트 하는 법 **
1) 제어판에서 Adobe Creative 제거 선택. 모두 체크 해제 후, [FB4.5]와 [AIR for APPLE IOS support] 둘을 선택하고 제거한다.
2) FB4.6 Trial을 Adobe 사이트에서 받아서 Serial 없이 Trial로 설치한다.(AIR for Apple IOS support도 같이 설치)
3) 설치된 FB 4.6을 실행하고 menu bar의 help를 눌러보면 "Deactivate Flash Builder...."가 보인다.
- 시리얼 인증상태는 그대로 유지됨 -



** 4.6으로 업데이트한 뒤 손봐줘야 할 부분.

1) [app_name]-app.xml 파일에서 

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<application xmlns="http://ns.adobe.com/air/application/2.6">

위 부분을

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<application xmlns="http://ns.adobe.com/air/application/3.1">

위 처럼 고친다. 
Problem View에서 Erorr라고 뜬다.
( existing project in folder에서 기존 프로젝트 들을 불러오면 4.6과 3.xA SDK 중에 선택하게 된다.
예전 Flex3.x 시리즈는 3.xA로, 이후 spark projects는 4.6으로 지정.)


2) color depth 16bit로 지정

<android>
<colorDepth>16bit</colorDepth>
        <manifestAdditions><![CDATA[

같은 파일에서 위 부분을 찾아 볼드체로 표시된 구문을 추가한다.



덧글

  • 골치덩어리 2012/08/27 17:03 # 삭제 답글

    4.5 설치후에 업데이트로 4.6이 가능하다는 말씀이신가요??
댓글 입력 영역


공지

어서오십시오.
트위터 : @FCliver
기저심리학 : 네이버카페
카카오톡 : FCliver
페이스북 : Fredric Cliver

통계 위젯 (화이트)

614
104
285308

접속자 위치